Need help with Sark?
Click the “chat” button below for chat support from the developer who created it, or find similar developers for support.

About the developer

tmr232
517 Stars 92 Forks MIT License 467 Commits 17 Opened issues

Description

IDAPython Made Easy

Services available

!
?

Need anything else?

Contributors list

# 87,434
jupyter
C
Markdow...
Electro...
364 commits
# 426,434
Python
C
ida-plu...
idapyth...
6 commits
# 440,969
Python
Shell
C
ida-plu...
5 commits
# 358,751
Python
C
ida-plu...
idapyth...
4 commits
# 231,702
C
idapyth...
idapyth...
CSS
3 commits
# 140,046
Shell
CSS
sed
idapyth...
3 commits
# 90,364
CSS
Shell
C
wmi
2 commits
# 253,503
Erlang
ida-plu...
idapyth...
sed
1 commit
# 375,743
Python
C
idapyth...
mach-o
1 commit
# 134,457
Shell
CSS
idapyth...
cheat
1 commit
# 590,869
Python
C
ida-plu...
idapyth...
1 commit

====

Sark

General

IDA Plugins & IDAPython Scripting Library.

For documentation, see

sark.rtfd.io 
_.

Installation (Python 3 & IDA 7.4)

For latest version (IDA7.4 & Python3):

.. code:: bash

pip3 install -U git+https://github.com/tmr232/Sark.git#egg=Sark

Or from PyPI:

.. code:: bash

pip3 install sark

For more info see

here 
_.

Python 2 & IDA < 7.4 ~~~~~~~~~~~~~~~~~~~~

As of the release of IDA 7.4, Sark is only actively developed for IDA7.4 or newer, and Python 3.

Python2 and older IDA is still supported for bugfixes & community contributions and is maintained on the

IDA-6.x branch 
_.

To install Sark for older IDA use:

.. code:: bash

pip2 install -U git+https://github.com/tmr232/[email protected]#egg=Sark

Or from PyPI:

.. code:: bash

pip2 install "sark<7.4"

Dependencies

  1. NetworkX 
    _
  2. wrapt 
    _

Plugins

Plugin

documentation 
_ and
installation instructions 
_.

We use cookies. If you continue to browse the site, you agree to the use of cookies. For more information on our use of cookies please see our Privacy Policy.