Need help with marionette-vdom?
Click the “chat” button below for chat support from the developer who created it, or find similar developers for support.

About the developer

themindfuldev
130 Stars 13 Forks Other 106 Commits 2 Opened issues

Description

Marionette.js views implemented with virtual-dom

Services available

!
?

Need anything else?

Contributors list

marionette-vdom

Build Status Coverage Status npm version Davis Dependency status

A

Marionette.View
and
Marionette.CompositeView
implementation with virtual-dom.

Version

  • If you are using Marionette.js v3+ you should use marionette-vdom v0.2+ (or the latest)
  • If you are using Marionette.js v2 you should use marionette-vdom v0.1.2-b

Usage

This module exposes

View
as the VDOM implementation for
Marionette.View
and
CompositeView
for
Marionette.CompositeView
:
var VDOMView = require('marionette-vdom').View;
var VDOMCompositeView = require('marionette-vdom').CompositeView;

How tos

To install:

npm install

To run the demo app:

npm run demo
open http://127.0.0.1:9966/demo/demo.html

To run the perf test:

npm run perf
open http://127.0.0.1:9966/perf/perf.html

To run the unit tests:

npm test

To generate binaries:

./build.sh
uglifyjs --compress --mangle -- marionette.vdom.js > marionette.vdom.min.js

Make sure to check out the change log.

Browser support

IE 9 on

We use cookies. If you continue to browse the site, you agree to the use of cookies. For more information on our use of cookies please see our Privacy Policy.