Github url


by python-poetry

python-poetry /poetry

Python dependency management and packaging made easy.

11.3K Stars 808 Forks Last release: about 1 month ago (1.0.9) MIT License 1.4K Commits 85 Releases

Available items

No Items, yet!

The developer of this repository has not created any items for sale yet. Need a bug fixed? Help with integration? A different license? Create a request here:

Poetry: Dependency Management for Python

Poetry helps you declare, manage and install dependencies of Python projects, ensuring you have the right stack everywhere.

Poetry Install

It supports Python 2.7 and 3.4+.

Tests Status

The complete documentation is available on the official website.


Poetry provides a custom installer that will install


isolated from the rest of your system by vendorizing its dependencies. This is the recommended way of installing



curl -sSL | python

Alternatively, you can download the

file and execute it separately.

If you want to install prerelease versions, you can do so by passing




python --preview

Similarly, if you want to install a specific version, you can use



python --version 0.7.0



to install


is also possible.

pip install --user poetry

Be aware, however, that it will also install poetry's dependencies which might cause conflicts.



Updating poetry to the latest stable version is as simple as calling the

self update


poetry self update

If you want to install prerelease versions, you can use the



poetry self update --preview

And finally, if you want to install a specific version you can pass it as an argument to

self update


poetry self update 1.0.0


If you are still on poetry version \< 1.0 use `poetry self:update` instead.

Enable tab completion for Bash, Fish, or Zsh


supports generating completion scripts for Bash, Fish, and Zsh. See

poetry help completions

for full details, but the gist is as simple as using one of the following:

# Bash poetry completions bash \> /etc/bash\_completion.d/poetry.bash-completion # Bash (Homebrew) poetry completions bash \> $(brew --prefix)/etc/bash\_completion.d/poetry.bash-completion # Fish poetry completions fish \> ~/.config/fish/completions/ # Fish (Homebrew) poetry completions fish \> (brew --prefix)/share/fish/vendor\_completions.d/ # Zsh poetry completions zsh \> ~/.zfunc/\_poetry # Zsh (Homebrew) poetry completions zsh \> $(brew --prefix)/share/zsh/site-functions/\_poetry # Zsh (Oh-My-Zsh) mkdir $ZSH/plugins/poetry poetry completions zsh \> $ZSH/plugins/poetry/\_poetry # Zsh (prezto) poetry completions zsh \> ~/.zprezto/modules/completion/external/src/\_poetry

Note: you may need to restart your shell in order for the changes to take effect.



, you must then add the following line in your




(not for homebrew setup):




is a tool to handle dependency installation as well as building and packaging of Python packages. It only needs one file to do all of that: the new, standardized



In other words, poetry uses


to replace






and the newly added



[tool.poetry] name = "my-package" version = "0.1.0" description = "The description of the package" license = "MIT" authors = [ "Sébastien Eustace <sebastien>"

readme = '' # Markdown files are supported

repository = ""
homepage = ""

keywords = ['packaging', 'poetry']

python = "~2.7 || ^3.2" # Compatible python versions must be declared here
toml = "^0.9"
# Dependencies with extras
requests = { version = "^2.13", extras = ["security"] }
# Python specific dependencies with prereleases allowed
pathlib2 = { version = "^2.2", python = "~2.7", allow-prereleases = true }
# Git dependencies
cleo = { git = "", branch = "master" }

# Optional dependencies (extras)
pendulum = { version = "^1.4", optional = true }

pytest = "^3.0"
pytest-cov = "^2.4"

my-script = 'my_package:main'

There are some things we can notice here:

  • It will try to enforce semantic versioning as the best practice in version naming.
  • You can specify the readme, included and excluded files: no more
    will also use VCS ignore files (like
    ) to populate the
  • Keywords (up to 5) can be specified and will act as tags on the packaging site.
  • The dependencies sections support caret, tilde, wildcard, inequality and multiple requirements.
  • You must specify the python versions for which your package is compatible.

will also detect if you are inside a virtualenv and install the packages accordingly. So,


can be installed globally and used everywhere.


also comes with a full fledged dependency resolution library.


Packaging systems and dependency management in Python are rather convoluted and hard to understand for newcomers. Even for seasoned developers it might be cumbersome at times to create all files needed in a Python project:






and the newly added



So I wanted a tool that would limit everything to a single configuration file to do: dependency management, packaging and publishing.

It takes inspiration in tools that exist in other languages, like


(PHP) or



And, finally, there is no reliable tool to properly resolve dependencies in Python, so I started


to bring an exhaustive dependency resolver to the Python community.

What about Pipenv?

In short: I do not like the CLI it provides, or some of the decisions made, and I think we can make a better and more intuitive one. Here are a few things that I don't like.

Dependency resolution

The dependency resolution is erratic and will fail even if there is a solution. Let's take an example:

pipenv install oslo.utils==1.4.0

will fail with this error:

Could not find a version that matches pbr!=0.7,!=2.1.0,\<1.0,\>=0.6,\>=2.0.0

while Poetry will get you the right set of packages:

poetry add oslo.utils=1.4.0

results in :

- Installing pytz (2018.3) - Installing netifaces (0.10.6) - Installing netaddr (0.7.19) - Installing oslo.i18n (2.1.0) - Installing iso8601 (0.1.12) - Installing six (1.11.0) - Installing babel (2.5.3) - Installing pbr (0.11.1) - Installing oslo.utils (1.4.0)

This is possible thanks to the efficient dependency resolver at the heart of Poetry.

Here is a breakdown of what exactly happens here:

oslo.utils (1.4.0)

depends on:

pbr (\>=0.6,!=0.7,\<1.0)
  • Babel (\>=1.3)
  • six (\>=1.9.0)
  • iso8601 (\>=0.1.9)
  • oslo.i18n (\>=1.3.0)
  • netaddr (\>=0.7.12)
  • netifaces (\>=0.10.4)

What interests us is

pbr (\>=0.6,!=0.7,\<1.0)


At this point, poetry will choose


which is the latest version that matches the constraint.

Next it will try to select


which is the latest version that matches

oslo.i18n (\>=1.3.0)


However this version requires

pbr (!=2.1.0,\>=2.0.0)

which is incompatible with


, so


will try to find a version of


that satisfies

pbr (\>=0.6,!=0.7,\<1.0)


By analyzing the releases of


, it will find


which requires

pbr (\>=0.11,\<2.0)

. At this point the rest of the resolution is straightforward since there is no more conflict.


We use cookies. If you continue to browse the site, you agree to the use of cookies. For more information on our use of cookies please see our Privacy Policy.