Need help with collision?
Click the “chat” button below for chat support from the developer who created it, or find similar developers for support.

About the developer

nunomaduro
3.9K Stars 110 Forks MIT License 544 Commits 1 Opened issues

Description

💥 Collision is a beautiful error reporting tool for command-line applications

Services available

!
?

Need anything else?

Contributors list

# 10,296
PHP
Laravel
Algolia
complex...
286 commits
# 1,653
PHP
Laravel
Compose...
framewo...
15 commits
# 25,992
PHP
Laravel
HTML
collisi...
15 commits
# 176,119
collisi...
PHP
Shell
Laravel
10 commits
# 4,852
PHP
Laravel
Symfony
Compose...
10 commits
# 48,014
PHP
Redis
Symfony
PHPUnit
10 commits
# 74,543
PHP
Laravel
Shell
collisi...
5 commits
# 44,356
PHP
Laravel
Compose...
githook
4 commits
# 150,301
collisi...
PHP
Shell
Laravel
3 commits
# 334,773
collisi...
PHP
Shell
Laravel
2 commits
# 272,305
PHP
Laravel
collisi...
excepti...
2 commits
# 2,417
Laravel
PHP
eloquen...
Google
2 commits
# 13,823
HTML
Perl
cms-fra...
Symfony
2 commits
# 62
PHP
vuejs
Laravel
psr
2 commits
# 11,586
PHP
Laravel
CSS
chatbot...
1 commit
# 31,016
Go
gorilla
golang
Laravel
1 commit
# 764
PHP
smtp
Laravel
jQuery
1 commit
# 402,784
collisi...
PHP
Shell
Laravel
1 commit
# 2,234
PHP
CSS
Laravel
chatbot...
1 commit
# 256,261
Laravel
PHP
HTML
collisi...
1 commit

Collision logo
Collision code example

Build Status Quality Score Total Downloads Latest Stable Version License


Collision was created by, and is maintained by Nuno Maduro, and is a package designed to give you beautiful error reporting when interacting with your app through the command line.

  • It's included on Laravel, the most popular free, open-source PHP framework in the world.
  • Built on top of the Whoops error handler.
  • Supports Laravel, Symfony, PHPUnit, and many other frameworks.

Installation & Usage

Requires PHP 7.3+

Require Collision using Composer:

composer require nunomaduro/collision --dev

Laravel Version Compatibility

Laravel

Collision
6.x 3.x
7.x 4.x
8.x 5.x

As an example, here is how to require Collision on Laravel 6.x:

composer require nunomaduro/collision:^3.0 --dev

Phpunit adapter

Phpunit must be 9.0 or higher.

Add the Collision

printerClass
to your
phpunit.xml
in the
phpunit
section:

No adapter

You need to register the handler in your code:

(new \NunoMaduro\Collision\Provider)->register();

Contributing

Thank you for considering to contribute to Collision. All the contribution guidelines are mentioned here.

You can have a look at the CHANGELOG for constant updates & detailed information about the changes. You can also follow the twitter account for latest announcements or just come say hi!: @enunomaduro

Support the development

Do you like this project? Support it by donating

License

Collision is an open-sourced software licensed under the MIT license.

Logo by Caneco.

We use cookies. If you continue to browse the site, you agree to the use of cookies. For more information on our use of cookies please see our Privacy Policy.