Need help with import-pypi?
Click the “chat” button below for chat support from the developer who created it, or find similar developers for support.

About the developer

miedzinski
202 Stars 4 Forks GNU General Public License v3.0 1 Commits 0 Opened issues

Description

One dependency to rule them all.

Services available

!
?

Need anything else?

Contributors list

# 38,444
Rust
C
termina...
Windows
1 commit

import-pypi

One dependency to rule them all.

asciicast

Installation

Copy

pypi.py
into your site-packages directory or straight into your project. Don't bother using pip, requirements.txt and all that crap.

Requires Python 3.4+.

Usage

import pypi

That's it. You can now import Django, NumPy, or whatever and it will always be there.

You can also pin your dependencies before importing them

import pypi

pypi.install('Django', '2.0.3')

import django

print(django.version) # 2.0.3

License

GNU GPLv3.

We use cookies. If you continue to browse the site, you agree to the use of cookies. For more information on our use of cookies please see our Privacy Policy.