rabbitpy

by gmr

A pure python, thread-safe, minimalistic and pythonic RabbitMQ client library

204 Stars 47 Forks Last release: almost 4 years ago (1.0.0) BSD 3-Clause "New" or "Revised" License 558 Commits 38 Releases

Available items

No Items, yet!

The developer of this repository has not created any items for sale yet. Need a bug fixed? Help with integration? A different license? Create a request here:

rabbitpy - RabbitMQ simplified

A pure python, thread-safe, minimalistic and Pythonic BSD Licensed AMQP/RabbitMQ library that supports Python 2.7+ and Python 3.4+. rabbitpy aims to provide a simple and easy to use API for interfacing with RabbitMQ, minimizing the programming overhead often found in other libraries.

|Version| |Downloads| |Status| |Coverage| |License|

Installation

rabbitpy may be installed via the Python package index with the tool of your choice. I prefer pip:

.. code:: bash

pip install rabbitpy

But there's always easy_install:

.. code:: bash

easy_install rabbitpy

Documentation

Documentation is available on

ReadTheDocs 
_.

Requirements

  • pamqp 
    _

Version History

Available at https://rabbitpy.readthedocs.org/en/latest/history.html

.. |Version| image:: https://img.shields.io/pypi/v/rabbitpy.svg? :target: http://badge.fury.io/py/rabbitpy

.. |Status| image:: https://img.shields.io/travis/gmr/rabbitpy.svg? :target: https://travis-ci.org/gmr/rabbitpy

.. |Coverage| image:: https://img.shields.io/codecov/c/github/gmr/rabbitpy.svg? :target: https://codecov.io/github/gmr/rabbitpy?branch=master

.. |Downloads| image:: https://img.shields.io/pypi/dm/rabbitpy.svg? :target: https://pypi.python.org/pypi/rabbitpy

.. |License| image:: https://img.shields.io/pypi/l/rabbitpy.svg? :target: https://rabbitpy.readthedocs.org

We use cookies. If you continue to browse the site, you agree to the use of cookies. For more information on our use of cookies please see our Privacy Policy.