Need help with expo-uber?
Click the “chat” button below for chat support from the developer who created it, or find similar developers for support.

About the developer

calebnance
171 Stars 48 Forks 73 Commits 0 Opened issues

Description

Uber UI Clone with React Native & Expo

Services available

!
?

Need anything else?

Contributors list

# 85,721
React N...
pixi
react-n...
HTML
57 commits

Uber: UI Clone with Expo

made with expo supports iOS and Android

follow @calebnance

Table of Contents

Install & Build

First, make sure you have Expo CLI installed:

npm install -g expo-cli

Install:

yarn
or
yarn install

Run Project Locally:

yarn dev
or
yarn start

Features

  • Expo SDK 40
  • iOS and Android
  • React Navigation v4
  • PropTypes

Linting

  • run:
    yarn lint
    for a list of linting warnings/error in cli
  • prettier and airbnb config
  • make sure you have prettier package installed:
  • then make sure to enable these options (packages → prettier):
    • eslint integration
    • stylelint integration
    • automatic format on save (toggle format on save)
  • be aware of the
    .prettierignore
    file

Release Notes

version 0.0.1 (current)

We use cookies. If you continue to browse the site, you agree to the use of cookies. For more information on our use of cookies please see our Privacy Policy.