Need help with deer?
Click the “chat” button below for chat support from the developer who created it, or find similar developers for support.

About the developer

VinF
462 Stars 118 Forks Other 480 Commits 4 Opened issues

Description

DEEp Reinforcement learning framework

Services available

!
?

Need anything else?

Contributors list

# 122,061
Python
Shell
policy-...
q-learn...
295 commits
# 169,998
Python
Shell
policy-...
q-learn...
137 commits
# 473,562
Python
Shell
policy-...
q-learn...
4 commits
# 496,553
Python
Shell
policy-...
q-learn...
3 commits
# 2,023
Shell
q-learn...
Python
C++
2 commits
# 67,081
Python
Shell
policy-...
q-learn...
1 commit
# 599,883
Python
Shell
policy-...
q-learn...
1 commit
# 594,472
Python
Shell
policy-...
q-learn...
1 commit

.. -- mode: rst --

|Travis|_ |Python27|_ |Python36|_ |PyPi|_ |License|_

.. |Travis| image:: https://travis-ci.org/VinF/deer.svg?branch=master .. _Travis: https://travis-ci.org/VinF/deer

.. |Python27| image:: https://img.shields.io/badge/python-2.7-blue.svg .. _Python27: https://badge.fury.io/py/deer

.. |Python36| image:: https://img.shields.io/badge/python-3.6-blue.svg .. _Python36: https://badge.fury.io/py/deer

.. |PyPi| image:: https://badge.fury.io/py/deer.svg .. _PyPi: https://badge.fury.io/py/deer

.. |License| image:: https://img.shields.io/badge/license-MIT-blue.svg .. _License: https://github.com/VinF/deer/blob/master/LICENSE

DeeR

DeeR is a python library for Deep Reinforcement. It is build with modularity in mind so that it can easily be adapted to any need. It provides many possibilities out of the box such as Double Q-learning, prioritized Experience Replay, Deep deterministic policy gradient (DDPG), Combined Reinforcement via Abstract Representations (CRAR). Many different environment examples are also provided (some of them using OpenAI gym).

Dependencies

This framework is tested to work under Python 3.6.

The required dependencies are NumPy >= 1.10, joblib >= 0.9. You also need Keras>=2.6.

For running the examples, Matplotlib >= 1.1.1 is required. For running the atari games environment, you need to install ALE >= 0.4.

Full Documentation

The documentation is available at : http://deer.readthedocs.io/

We use cookies. If you continue to browse the site, you agree to the use of cookies. For more information on our use of cookies please see our Privacy Policy.