Need help with PHPCompatibility?
Click the “chat” button below for chat support from the developer who created it, or find similar developers for support.

About the developer

1.6K Stars 148 Forks GNU Lesser General Public License v3.0 2.6K Commits 74 Opened issues


PHP Compatibility check for PHP_CodeSniffer

Services available


Need anything else?

Contributors list

PHP Compatibility Coding Standard for PHP CodeSniffer

Latest Stable Version Latest Unstable Version Awesome License Flattr this git repo

CS Build Status Test Build Status Scrutinizer Code Quality Coverage Status

Minimum PHP Version Tested on PHP 5.4 to nightly

This is a set of sniffs for PHP CodeSniffer that checks for PHP cross-version compatibility. It will allow you to analyse your code for compatibility with higher and lower versions of PHP.

PHP Version Support

The project aims to cover all PHP compatibility changes introduced since PHP 5.0 up to the latest PHP release. This is an ongoing process and coverage is not yet 100% (if, indeed, it ever could be). Progress is tracked on our GitHub issue tracker.

Pull requests that check for compatibility issues in PHP 4 code - in particular between PHP 4 and PHP 5.0 - are very welcome as there are still situations where people need help upgrading legacy systems. However, coverage for changes introduced before PHP 5.1 will remain patchy as sniffs for this are not actively being developed at this time.


  • PHP 5.4+
  • PHP CodeSniffer: 2.6.0+ or 3.1.0+.

The sniffs are designed to give the same results regardless of which PHP version you are using to run PHP CodeSniffer. You should get consistent results independently of the PHP version used in your test environment, though for the best results it is recommended to run the sniffs on a recent PHP version in combination with a recent PHP_CodeSniffer version.

For running the sniffs on PHP 7.3, it is recommended to use PHPCodeSniffer 3.3.1+, or, if needs be, PHPCodeSniffer 2.9.2. PHPCodeSniffer < 2.9.2/3.3.1 is not fully compatible with PHP 7.3, which effectively means that PHPCompatibility can't be either. While the sniffs will still work in _most cases, you can expect PHP warnings to be thrown.

For running the sniffs on PHP 7.4, it is recommended to use PHP_CodeSniffer 3.5.0+ for the same reasons.

As of version 8.0.0, the PHPCompatibility standard can also be used with PHP CodeSniffer 3.x. As of version 9.0.0, support for PHP CodeSniffer 1.5.x and low 2.x versions < 2.3.0 has been dropped. As of version 10.0.0, support for PHP < 5.4 and PHP CodeSniffer < 2.6.0 has been dropped.

Thank you

Thanks to all contributors for their valuable contributions.

Thanks to WP Engine for their support on the PHP 7.0 sniffs.

:warning: Upgrading to PHPCompatibility 9.0.0 :warning:

This library has been reorganized. All sniffs have been placed in categories and a significant number of sniffs have been renamed.

If you use the complete

standard without
directives in a custom ruleset and do not (yet) use the new-style PHP_CodeSniffer annotation as introduced in PHP_CodeSniffer 3.2.0, this will have no noticeable effect and everything should work as before.

However, if you do use

directives for PHPCompatibility sniffs in a custom ruleset or if you use the new-style PHP_CodeSniffer inline annotations, you will need to update these when upgrading. This should be a one-time only change. The changelog contains detailed information about all the sniff renames.

Please read the changelog for version 9.0.0 carefully before upgrading.

Installation in a Composer project (method 1)

  • Add the following lines to the
    section of your
    "require-dev": {
        "phpcompatibility/php-compatibility": "*"
    "prefer-stable" : true
  • Next, PHP CodeSniffer has to be informed of the location of the standard.

    • If PHPCompatibility is the only external PHP CodeSniffer standard you use, you can add the following to your
      file to automatically run the necessary command:
      "scripts": {
          "post-install-cmd": "\"vendor/bin/phpcs\" --config-set installed_paths vendor/phpcompatibility/php-compatibility",
          "post-update-cmd" : "\"vendor/bin/phpcs\" --config-set installed_paths vendor/phpcompatibility/php-compatibility"
    • Alternatively - and strongly recommended if you use more than one external PHP CodeSniffer standard - you can use any of the following Composer plugins to handle this for you.

    Just add the Composer plugin you prefer to the

    section of your
    file. * DealerDirect/phpcodesniffer-composer-installer:"^0.6.0" * higidi/composer-phpcodesniffer-standards-plugin * SimplyAdmire/ComposerPlugins. This plugin might still work, but appears to be abandoned. - As a last alternative in case you use a custom ruleset, and only if you use PHP CodeSniffer version 2.6.0 or higher, you can tell PHP CodeSniffer the path to the PHPCompatibility standard by adding the following snippet to your custom ruleset:
  • Run

    composer update --lock
    to install both PHP CodeSniffer, the PHPCompatibility coding standard and - optionally - the Composer plugin.
  • Verify that the PHPCompatibility standard is registered correctly by running

    ./vendor/bin/phpcs -i
    on the command line. PHPCompatibility should be listed as one of the available standards.
  • Now you can use the following command to inspect your code:

    ./vendor/bin/phpcs -p . --standard=PHPCompatibility

Installation via a git check-out to an arbitrary directory (method 2)

  • Install PHP CodeSniffer via your preferred method.

    PHP CodeSniffer offers a variety of installation methods to suit your work-flow: Composer, PEAR, a Phar file, zipped/tarred release archives or checking the repository out using Git.

    Pro-tip: Register the path to PHPCS in your system

    environment variable to make the
    command available from anywhere in your file system.
  • Download the latest PHPCompatibility release and unzip/untar it into an arbitrary directory.

    You can also choose to clone the repository using git to easily update your install regularly.

  • Add the path to the directory in which you placed your copy of the PHPCompatibility repo to the PHP CodeSniffer configuration using the below command from the command line:

    phpcs --config-set installed_paths /path/to/PHPCompatibility
    I.e. if you placed the
    repository in the
    directory, you will need to add that directory to the PHP CodeSniffer
    configuration variable

Warning: :warning: The

command overwrites any previously set
. If you have previously set
for other external standards, run
phpcs --config-show
first and then run the
command with all the paths you need separated by comma's, i.e.:
   phpcs --config-set installed_paths /path/1,/path/2,/path/3

Pro-tip: Alternatively, in case you use a custom ruleset and only if you use PHP CodeSniffer version 2.6.0 or higher, you can tell PHP CodeSniffer the path to the PHPCompatibility standard(s) by adding the following snippet to your custom ruleset:

* Verify that the PHPCompatibility standard is registered correctly by running
phpcs -i
on the command line. PHPCompatibility should be listed as one of the available standards. * Now you can use the following command to inspect your code:
    phpcs -p . --standard=PHPCompatibility

Sniffing your code for compatibility with specific PHP version(s)

  • Run the coding standard from the command-line with
    phpcs -p . --standard=PHPCompatibility
  • By default, you will only receive notifications about deprecated and/or removed PHP features.
  • To get the most out of the PHPCompatibility standard, you should specify a
    to check against. That will enable the checks for both deprecated/removed PHP features as well as the detection of code using new PHP features.
    • You can run the checks for just one specific PHP version by adding
      --runtime-set testVersion 5.5
      to your command line command.
    • You can also specify a range of PHP versions that your code needs to support. In this situation, compatibility issues that affect any of the PHP versions in that range will be reported:
      --runtime-set testVersion 5.3-5.5
    • As of PHPCompatibility 7.1.3, you can omit one part of the range if you want to support everything above or below a particular version, i.e. use
      --runtime-set testVersion 7.0-
      to run all the checks for PHP 7.0 and above.
  • By default the report will be sent to the console, if you want to save the report to a file, add the following to the command line command:
    . For more information and other reporting options, check the PHP CodeSniffer wiki.

Using a framework/CMS/polyfill specific ruleset

As of mid 2018, a limited set of framework/CMS specific rulesets is available. These rulesets are hosted in their own repositories. *

GitHub | Packagist *
GitHub | Packagist

Since the autumn of 2018, there are also a number of PHP polyfill specific rulesets available: *

GitHub | Packagist: accounts for @ircmaxell's
polyfill library. *
GitHub | Packagist: contains two rulesets which account for the Paragonie
polyfill libraries respectively. *
GitHub | Packagist: contains a number of rulesets which account for various PHP polyfill libraries offered by the Symfony project. For more details about the available rulesets, please check out the README of the PHPCompatibilitySymfony repository.

If you want to make sure you have all PHPCompatibility rulesets available at any time, you can use the

package GitHub | Packagist.

IMPORTANT: Framework/CMS/Polyfill specific rulesets do not set the minimum PHP version for your project, so you will still need to pass a

to get the most accurate results.

Using a custom ruleset

Like with any PHP CodeSniffer standard, you can add PHPCompatibility to a custom PHP CodeSniffer ruleset.

    My rules for PHP CodeSniffer

<!-- Run against the PHPCompatibility ruleset -->
<rule ref="PHPCompatibility"></rule>

<!-- Run against a second ruleset -->
<rule ref="PSR2"></rule>

You can also set the

from within the ruleset:

Other advanced options, such as changing the message type or severity of select sniffs, as described in the PHPCS Annotated ruleset wiki page are, of course, also supported.

in the ruleset versus command-line

In PHPCS 3.2.0 and lower, once you set the

in the ruleset, you could not overrule it from the command-line anymore. Starting with PHPCS 3.3.0, a
set via the command-line will overrule the
in the ruleset.

This allows for more flexibility when, for instance, your project needs to comply with PHP

, but you have a bootstrap file which needs to be compatible with PHP

PHPCompatibility specific options

At this moment, there is one sniff which has a property which can be set via the ruleset. More custom properties may become available in the future.


sniff checks for removed extensions based on the function prefix used for these extensions. This might clash with userland functions using the same function prefix.

To whitelist userland functions, you can pass a comma-delimited list of function names to the sniff.


Projects extending PHPCompatibility

There are hundreds of public projects using PHPCompatibility or extending on top of it. A short list of some that you might know or have a look at : * adamculp/php-code-quality - a Docker image doing a lot of code quality checks * VFAC/PHP7Compatibility - a Docker container to check PHP7 Compatibility * grumphp-php-compatibility - A plugin for GrumPHP * PHPCompatibility Checker WordPress plugin : Wordpress site and Github * WordPress Tide project * PHPStorm has built-in support for PHPCompatibility * Moodle codechecker - A plugin for Moodle coding style, including PHPCompatibility.


Contributions are very welcome. Please read the CONTRIBUTING documentation to get started.


This code is released under the GNU Lesser General Public License (LGPL). For more information, visit

We use cookies. If you continue to browse the site, you agree to the use of cookies. For more information on our use of cookies please see our Privacy Policy.