Need help with haxe?
Click the “chat” button below for chat support from the developer who created it, or find similar developers for support.

About the developer

HaxeFoundation
4.1K Stars 551 Forks 19.9K Commits 1.0K Opened issues

Description

Haxe - The Cross-Platform Toolkit

Services available

!
?

Need anything else?

Contributors list

GitHub Build Status SauceLabs Test Status Gitter Discord

Haxe is an open source toolkit that allows you to easily build cross-platform tools and applications that target many mainstream platforms. The Haxe toolkit includes:

  • The Haxe programming language, a modern, high-level, strictly-typed programming language
  • The Haxe cross-compiler, a state-of-the-art, lightning-speed compiler for many targets
  • The Haxe standard library, a complete, cross-platform library of common functionality

Haxe allows you to compile for the following targets:

You can try Haxe directly from your browser at try.haxe.org!

For more information about Haxe, head to the official Haxe website.

License

The Haxe project has several licenses, covering different parts of the projects.

  • The Haxe compiler is released under the GNU General Public License version 2 or any later version.
  • The Haxe standard library is released under the MIT license.
  • The Neko virtual machine is released under the MIT license. Its bundled runtime libraries (ndll) and tools are released under open source licenses as described in https://github.com/HaxeFoundation/neko/blob/master/LICENSE

For the complete Haxe licenses, please see https://haxe.org/foundation/open-source.html or extra/LICENSE.txt.

Installing Haxe

The latest stable release is available at https://haxe.org/download/. Pre-built binaries are available for your platform:

Automated development builds are available from build.haxe.org.

Building from source

See extra/BUILDING.md.

Using Haxe

For information on using Haxe, consult the Haxe documentation:

Community

You can get help and talk with fellow Haxers from around the world via:

:+1: Get notified of the latest Haxe news, follow us on Twitter, Facebook and don't forget to read the Haxe roundups.

Version compatibility

Haxe

Neko SWF Python HL PHP Lua
2.* 1.* 8-10 - - - -
3.0.0 2.0.0 - - 5.1+ -
3.2.0 12-14 3.2+ - -
3.3.0 2.1.0 21 - 5.1, 5.2, 5.3, LuaJIT 2.0, 2.1
3.4.0 1.1 5.4+ and 7.0+ (with

-D php7
)
4.0.0 2.3.0 1.11 7.0+

Contributing

See CONTRIBUTING.md for more. Thank you!

We use cookies. If you continue to browse the site, you agree to the use of cookies. For more information on our use of cookies please see our Privacy Policy.